GoldenDict 高级用户使用手册

好的。导入欧路的时候,特别爽快,几秒钟就可以了。

那应该是欧陆使用了mdx自带的索引 ---- mdx包括mdd文件自身是有索引信息的

GoldenDict 可不可以也只使用mdx自带索引,词条内容就不要index了,因为这种体积的词典,不太需要GoldenDict的全文搜索功能。

gd可以设置词条超过一定数量不全文搜索

全文搜索是个大杀器 ---- 只是我觉着针对mdx格式词典做全文效率太低了----这个应该是mdx的劣势吧,整个mdx的源码中有效信息的比重太低了,全是一堆html标签,处理起来自然就慢

深蓝词典就很快,虽然也不完美,隔个标签就出问题。欧路那个大概是骗人的,只能索引自家格式

感谢告知,正在尝试。设置了超过200万的不全文搜索。

这个大概跟正则引擎有关系吧,Qt用的应该是pcre的实现,emeditor默认自带的boost的就很好

昨天这样设置了下还是不行,永远index不完… 放弃了 还是用欧路吧

你应该先看有多少词条,然后再设上限的。我设的50万

后来设置了50万,还是不行。词条至少200万

我记错了,看了下代码,设上限应该是能够生效的,以文章总数为准

可能导入成功了以后,设置上限可以。现在我这个问题是一直在导入,进入不了词典界面。

先杀掉gd进程,手工修改配置文件config.nwx,把那个true改成false,再次开启GD后去修改响应参数:
<fts searchMode=“0” matchCase=“false” maxArticlesPerDictionary=“100” maxDistanceBetweenWords=“2” useMaxArticlesPerDictionary=“false” useMaxDistanceBetweenWords=“false” dialogGeometry=“1554 253 709 751” disabledTypes=“AARD,BGL,DICTD,MDICT,SDICT,SLOB,STARDICT,XDXF,ZIM,EPWING,GLS” enabled=“true” ignoreWordsOrder=“false” ignoreDiacritics=“false” maxDictionarySize=“0” />

Thank for your sharing. 一定花了不少时间。

用的mac版的GoldenDict,不知道应该对应改哪里 :flushed: 我搜了下所有的配置文件,好像没有上面相关的配置。

mac的是官方版吧,配置文件结构跟改版的不一样

是的,所以不知道改哪里

官方版的配置文件名称是config(没有后缀),配置文件中的节点为fullTextSearch,其它的属性名称如enabledmaxDictionarySize等跟我上面的几乎一致,但只要用1代替我的true0代替我的false就行了,通过菜单可快速定位配置文件所在的目录